Wednesday, March 20, 2013

MPLS L2 VPN - Ethernet To Ethernet/PPP To PPP ATOM: It's All About Pseudo-Wires






pseudowire-class ATOM_ETH_TO_ETH
 encapsulation mpls <
Choosing MPLS Here Basically Suggests that we are using AToM Not L2TPv3
!
interface FastEthernet1/0
 no ip address
 speed auto
 duplex auto
 no keepalive
 xconnect 2.2.2.2 12 pw-class ATOM_ETH_TO_ETH
!


R2's XCONNECT Configuration

pseudowire-class ATOM_ETH_TO_ETH
 encapsulation mpls

!

interface FastEthernet1/0
 no ip address
 speed auto
 duplex auto
 no keepalive
 xconnect 1.1.1.1 12 pw-class ATOM_ETH_TO_ETH

!

Verification











PPP To PPP Variation







R1
===
!
!
! Last configuration change at 17:46:55 UTC Wed Mar 20 2013
!
version 12.2
service timestamps debug datetime msec
service timestamps log datetime msec
!
hostname R1
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
ip source-route
no ip icmp rate-limit unreachable
ip cef
!
!
!
!
no ip domain lookup
no ipv6 cef
!
!
multilink bundle-name authenticated
mpls label protocol ldp
!
!
!
!
ip tcp synwait-time 5
pseudowire-class ATOM_ETH_TO_ETH
 encapsulation mpls
!
!
!
!
!
!
!
interface Loopback0
 ip address 1.1.1.1 255.255.255.255
!
interface FastEthernet0/0
 no ip address
 shutdown
 duplex half
!
interface FastEthernet1/0
 no ip address
 speed auto
 duplex auto
 no keepalive
 xconnect 2.2.2.2 12 pw-class ATOM_ETH_TO_ETH
!
interface FastEthernet1/1
 ip address 13.0.0.1 255.255.255.0
 ip router isis 1
 speed auto
 duplex auto
 mpls ip
!
router isis 1
 net 49.1234.0000.0000.0001.00
 is-type level-2-only
 passive-interface Loopback0
!
no ip http server
no ip http secure-server
!
!
!
no cdp run
!
!
!
control-plane
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
 stopbits 1
line aux 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
 stopbits 1
line vty 0 4
 login
!
end
 
R2
==

!
!
! Last configuration change at 17:48:05 UTC Wed Mar 20 2013
!
version 12.2
service timestamps debug datetime msec
service timestamps log datetime msec
!
hostname R2
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
ip source-route
no ip icmp rate-limit unreachable
ip cef
!
!
!
!
no ip domain lookup
no ipv6 cef
!
!
multilink bundle-name authenticated
mpls label protocol ldp
!
!
!
!
ip tcp synwait-time 5
pseudowire-class ATOM_ETH_TO_ETH
 encapsulation mpls
!
!
!
!
!
!
!
interface Loopback0
 ip address 2.2.2.2 255.255.255.255
!
interface FastEthernet0/0
 no ip address
 shutdown
 duplex half
!
interface FastEthernet1/0
 no ip address
 speed auto
 duplex auto
 no keepalive
 xconnect 1.1.1.1 12 pw-class ATOM_ETH_TO_ETH
!
interface FastEthernet1/1
 ip address 24.0.0.2 255.255.255.0
 ip router isis 1
 speed auto
 duplex auto
 mpls ip
!
router isis 1
 net 49.1234.0000.0000.0002.00
 is-type level-2-only
 passive-interface Loopback0
!
no ip http server
no ip http secure-server
!
!
!
no cdp run
!
!
!
control-plane
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
 stopbits 1
line aux 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
 stopbits 1
line vty 0 4
 login
!
end
 

R3
==
 !
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R3
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
no ip icmp rate-limit unreachable
ip cef
!
!
!
!
no ip domain lookup
mpls label protocol ldp
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
ip tcp synwait-time 5
!
!
!
interface Loopback0
 ip address 3.3.3.3 255.255.255.255
 ip router isis 1
!
interface FastEthernet0/0
 ip address 34.0.0.3 255.255.255.0
 ip router isis 1
 duplex auto
 speed auto
 mpls ip
!
interface FastEthernet0/1
 ip address 13.0.0.3 255.255.255.0
 ip router isis 1
 duplex auto
 speed auto
 mpls ip
!
router isis 1
 net 49.1234.0000.0000.0003.00
 is-type level-2-only
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
!
no cdp run
!
!
control-plane
!
!
!
!
!
!
!
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line aux 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line vty 0 4
 login
!
!
end
 
R4
==
 !
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R4
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
no ip icmp rate-limit unreachable
ip cef
!
!
!
!
no ip domain lookup
mpls label protocol ldp
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
ip tcp synwait-time 5
!
!
!
interface Loopback0
 ip address 4.4.4.4 255.255.255.255
!
interface FastEthernet0/0
 ip address 24.0.0.4 255.255.255.0
 ip router isis 1
 duplex auto
 speed auto
 mpls ip
!
interface FastEthernet0/1
 ip address 34.0.0.4 255.255.255.0
 ip router isis 1
 duplex auto
 speed auto
 mpls ip
!
router isis 1
 net 49.1234.0000.0000.0004.00
 is-type level-2-only
 passive-interface Loopback0
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line aux 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line vty 0 4
 login
!
!
end
 
R5
==

!
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R5
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
no ip icmp rate-limit unreachable
ip cef
!
!
!
!
no ip domain lookup
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
ip tcp synwait-time 5
!
!
!
interface Loopback0
 ip address 5.5.5.5 255.255.255.255
!
interface FastEthernet0/0
 ip address 150.0.0.5 255.255.255.0
 duplex auto
 speed auto
!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
router ospf 1
 log-adjacency-changes
 network 5.5.5.5 0.0.0.0 area 0
 network 150.0.0.5 0.0.0.0 area 0
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
!
no cdp run
!
!
control-plane
!
!
!
!
!
!
!
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line aux 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line vty 0 4
 login
!
!
end
 

R6
==

!
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R6
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
no ip icmp rate-limit unreachable
ip cef
!
!
!
!
no ip domain lookup
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
ip tcp synwait-time 5
!
!
!
interface Loopback0
 ip address 6.6.6.6 255.255.255.255
!
interface FastEthernet0/0
 ip address 150.0.0.6 255.255.255.0
 duplex auto
 speed auto
!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
router ospf 1
 log-adjacency-changes
 network 6.6.6.6 0.0.0.0 area 0
 network 150.0.0.6 0.0.0.0 area 0
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
!
no cdp run
!
!
control-plane
!
!
!
!
!
!
!
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line aux 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line vty 0 4
 login
!
!
end
 

HTH...
Deepak Arora
Evil CCIE

Thursday, March 14, 2013

MPLS Inter AS VPN Option B AKA Option 2








R1 Final Configuration

!
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R1
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
no ip icmp rate-limit unreachable
ip cef
!
!
!
!
ip vrf A
 rd 100:1
 route-target export 1:1
 route-target import 1:1
!
ip vrf B
 rd 100:2
 route-target export 2:2
 route-target import 2:2
!
no ip domain lookup
mpls label protocol ldp
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
ip tcp synwait-time 5
!
!
!
interface Loopback0
 ip address 1.1.1.1 255.255.255.255
!
interface FastEthernet0/0
 ip address 14.0.0.1 255.255.255.0
 ip router isis 1
 duplex auto
 speed auto
 mpls ip
!
interface FastEthernet0/1
 ip vrf forwarding A
 ip address 12.0.0.1 255.255.255.0
 duplex auto
 speed auto
!
interface FastEthernet1/0
 ip vrf forwarding B
 ip address 13.0.0.1 255.255.255.0
 duplex auto
 speed auto
!
router eigrp 1
 auto-summary
 !
 address-family ipv4 vrf A
  redistribute bgp 100 metric 1 1 1 1 1
  network 12.0.0.1 0.0.0.0
  no auto-summary
  autonomous-system 100
 exit-address-family
!
router ospf 1 vrf B
 log-adjacency-changes
 redistribute bgp 100 subnets
 network 13.0.0.1 0.0.0.0 area 0
!
router isis 1
 net 49.1456.0000.0000.0001.00
 is-type level-2-only
 passive-interface Loopback0
!
router bgp 100
 no synchronization
 bgp log-neighbor-changes
 neighbor 4.4.4.4 remote-as 100
 neighbor 4.4.4.4 update-source Loopback0
 no auto-summary
 !
 address-family vpnv4
  neighbor 4.4.4.4 activate
  neighbor 4.4.4.4 send-community extended
 exit-address-family
 !
 address-family ipv4 vrf B
  redistribute ospf 1 vrf B match internal external 1 external 2
  no synchronization
 exit-address-family
 !
 address-family ipv4 vrf A
  redistribute eigrp 100
  no synchronization
 exit-address-family
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
!
no cdp run
!
!
control-plane
!
!
!
!
!
!
!
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line aux 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line vty 0 4
 login
!
!
end

R2 Final Configuration 

 !
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R2
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
no ip icmp rate-limit unreachable
ip cef
!
!
!
!
no ip domain lookup
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
ip tcp synwait-time 5
!
!
!
interface Loopback0
 ip address 2.2.2.2 255.255.255.255
!
interface FastEthernet0/0
 ip address 12.0.0.2 255.255.255.0
 duplex auto
 speed auto
!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
router eigrp 100
 network 2.2.2.2 0.0.0.0
 network 12.0.0.2 0.0.0.0
 no auto-summary
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
!
no cdp run
!
!
control-plane
!
!
!
!
!
!
!
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line aux 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line vty 0 4
 login
!
!
end

R3 Final Configuration

!
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R3
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
no ip icmp rate-limit unreachable
ip cef
!
!
!
!
no ip domain lookup
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
ip tcp synwait-time 5
!
!
!
interface Loopback0
 ip address 3.3.3.3 255.255.255.255
!
interface FastEthernet0/0
 ip address 13.0.0.3 255.255.255.0
 duplex auto
 speed auto
!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
router ospf 1
 log-adjacency-changes
 network 3.3.3.3 0.0.0.0 area 0
 network 13.0.0.3 0.0.0.0 area 0
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
!
no cdp run
!
!
control-plane
!
!
!
!
!
!
!
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line aux 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line vty 0 4
 login
!
!
end


R4 Final Configuration

!
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R4
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
no ip icmp rate-limit unreachable
ip cef
!
!
!
!
no ip domain lookup
mpls label protocol ldp
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
ip tcp synwait-time 5
!
!
!
interface Loopback0
 ip address 4.4.4.4 255.255.255.255
!
interface FastEthernet0/0
 ip address 14.0.0.4 255.255.255.0
 ip router isis 1
 duplex auto
 speed auto
 mpls ip
!
interface FastEthernet0/1
 ip address 45.0.0.4 255.255.255.0
 duplex auto
 speed auto
!
router isis 1
 net 49.1456.0000.0000.0004.00
 is-type level-2-only
 passive-interface Loopback0
!
router bgp 100
 no synchronization
 no bgp default route-target filter
 bgp log-neighbor-changes
 neighbor 1.1.1.1 remote-as 100
 neighbor 1.1.1.1 update-source Loopback0
 neighbor 45.0.0.5 remote-as 200
 no auto-summary
 !
 address-family vpnv4
  neighbor 1.1.1.1 activate
  neighbor 1.1.1.1 send-community extended
  neighbor 1.1.1.1 next-hop-self
  neighbor 45.0.0.5 activate
  neighbor 45.0.0.5 send-community extended
 exit-address-family
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line aux 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line vty 0 4
 login
!
!
end


R5 Final Configuration

!
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R5
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
no ip icmp rate-limit unreachable
ip cef
!
!
!
!
no ip domain lookup
mpls label protocol ldp
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
ip tcp synwait-time 5
!
!
!
interface Loopback0
 ip address 5.5.5.5 255.255.255.255
!
interface FastEthernet0/0
 ip address 56.0.0.5 255.255.255.0
 ip router isis 1
 duplex auto
 speed auto
 mpls ip
!
interface FastEthernet0/1
 ip address 45.0.0.5 255.255.255.0
 duplex auto
 speed auto
!
router isis 1
 net 49.1456.0000.0000.0005.00
 is-type level-2-only
 passive-interface Loopback0
!
router bgp 200
 no synchronization
 no bgp default route-target filter
 bgp log-neighbor-changes
 neighbor 6.6.6.6 remote-as 200
 neighbor 6.6.6.6 update-source Loopback0
 neighbor 45.0.0.4 remote-as 100
 no auto-summary
 !
 address-family vpnv4
  neighbor 6.6.6.6 activate
  neighbor 6.6.6.6 send-community extended
  neighbor 6.6.6.6 next-hop-self
  neighbor 45.0.0.4 activate
  neighbor 45.0.0.4 send-community extended
 exit-address-family
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
!
no cdp run
!
!
control-plane
!
!
!
!
!
!
!
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line aux 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line vty 0 4
 login
!
!
end

R6 Final Configuration

!
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R6
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
no ip icmp rate-limit unreachable
ip cef
!
!
!
!
ip vrf A
 rd 200:1
 route-target export 1:1
 route-target import 1:1
!
ip vrf B
 rd 200:2
 route-target export 2:2
 route-target import 2:2
!
no ip domain lookup
mpls label protocol ldp
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
ip tcp synwait-time 5
!
!
!
interface Loopback0
 ip address 6.6.6.6 255.255.255.255
!
interface FastEthernet0/0
 ip address 56.0.0.6 255.255.255.0
 ip router isis 1
 duplex auto
 speed auto
 mpls ip
!
interface FastEthernet0/1
 ip vrf forwarding A
 ip address 67.0.0.6 255.255.255.0
 duplex auto
 speed auto
!
interface FastEthernet1/0
 ip vrf forwarding B
 ip address 68.0.0.6 255.255.255.0
 duplex auto
 speed auto
!
router eigrp 1
 auto-summary
 !
 address-family ipv4 vrf A
  redistribute bgp 200 metric 1 1 1 1 1
  network 67.0.0.6 0.0.0.0
  no auto-summary
  autonomous-system 100
 exit-address-family
!
router ospf 1 vrf B
 log-adjacency-changes
 redistribute bgp 200 subnets
 network 68.0.0.6 0.0.0.0 area 0
!
router isis 1
 net 49.1456.0000.0000.0006.00
 is-type level-2-only
 passive-interface Loopback0
!
router bgp 200
 no synchronization
 bgp log-neighbor-changes
 neighbor 5.5.5.5 remote-as 200
 neighbor 5.5.5.5 update-source Loopback0
 no auto-summary
 !
 address-family vpnv4
  neighbor 5.5.5.5 activate
  neighbor 5.5.5.5 send-community extended
 exit-address-family
 !
 address-family ipv4 vrf B
  redistribute ospf 1 vrf B match internal external 1 external 2
  no synchronization
 exit-address-family
 !
 address-family ipv4 vrf A
  redistribute eigrp 100
  no synchronization
 exit-address-family
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
!
no cdp run
!
!
control-plane
!
!
!
!
!
!
!
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line aux 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line vty 0 4
 login
!
!
end

R7 Final Configuration

!
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R7
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
no ip icmp rate-limit unreachable
ip cef
!
!
!
!
no ip domain lookup
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
ip tcp synwait-time 5
!
!
!
interface Loopback0
 ip address 7.7.7.7 255.255.255.255
!
interface FastEthernet0/0
 ip address 67.0.0.7 255.255.255.0
 duplex auto
 speed auto
!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
router eigrp 100
 network 7.7.7.7 0.0.0.0
 network 67.0.0.7 0.0.0.0
 no auto-summary
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
!
no cdp run
!
!
control-plane
!
!
!
!
!
!
!
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line aux 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line vty 0 4
 login
!
!
end

R8 Final Configuration

!
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R8
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
no ip icmp rate-limit unreachable
ip cef
!
!
!
!
no ip domain lookup
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
ip tcp synwait-time 5
!
!
!
interface Loopback0
 ip address 8.8.8.8 255.255.255.255
!
interface FastEthernet0/0
 ip address 68.0.0.8 255.255.255.0
 duplex auto
 speed auto
!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
router ospf 1
 log-adjacency-changes
 network 8.8.8.8 0.0.0.0 area 0
 network 68.0.0.8 0.0.0.0 area 0
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
!
no cdp run
!
!
control-plane
!
!
!
!
!
!
!
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line aux 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line vty 0 4
 login
!
!
end

Further Readings:







Deepak Arora
Evil CCIE

Monday, March 11, 2013

ISIS Route Leaking In IOS-XR... Coming Soon



RP/0/0/CPU0:XR1#sh route isis | i 3.3.3.3
i L2 3.3.3.3/32 [115/30] via 20.6.19.6, 00:29:27, GigabitEthernet0/1/0/0.619
RP/0/0/CPU0:XR1#sh route isis | i 4.4.4.4
i L2 4.4.4.4/32 [115/20] via 20.6.19.6, 00:29:36, GigabitEthernet0/1/0/0.619

Step 1: Create Route Policy
=====================

RP/0/0/CPU0:XR1#sh run route-policy ISIS
route-policy ISIS
  if destination in (3.3.3.3/32, 4.4.4.4/32) then
    pass
  endif
end-policy

!

Step 2: Map The Policy To ISIS Process
==============================

RP/0/0/CPU0:XR1#sh run router isis
router isis 1
 net 49.1920.0000.0000.0019.00
 address-family ipv4 unicast
  propagate level 2 into level 1 route-policy ISIS
 !
 interface Loopback0
  passive
  circuit-type level-2-only
  address-family ipv4 unicast
  !
 !
 interface GigabitEthernet0/1/0/0.519
  circuit-type level-2-only
  address-family ipv4 unicast
  !
 !
 interface GigabitEthernet0/1/0/0.619
  circuit-type level-2-only
  address-family ipv4 unicast
  !
 !
 interface POS0/6/0/0
  circuit-type level-1
  address-family ipv4 unicast
  !
 !
!


Verification
=========

Before on XR2
===========
RP/0/3/CPU0:XR2#sh ip route isis

i*L1 0.0.0.0/0 [115/10] via 10.19.20.19, 00:23:22, POS0/7/0/0


After on XR2
==========

RP/0/3/CPU0:XR2#sh ip route isis


i*L1 0.0.0.0/0 [115/10] via 10.19.20.19, 00:23:46, POS0/7/0/0
i ia 3.3.3.3/32 [115/40] via 10.19.20.19, 00:00:05, POS0/7/0/0
i ia 4.4.4.4/32 [115/30] via 10.19.20.19, 00:00:05, POS0/7/0/0

 

Other Relevant Configuration
======================

RP/0/3/CPU0:XR2#sh run router isis

router isis 1
 is-type level-1
 net 49.1920.0000.0000.0020.00
 interface Loopback0
  passive
  address-family ipv4 unicast
  !
 !
 interface POS0/7/0/0
  address-family ipv4 unicast
  !
 !
!
  
Deepak Arora
Evil CCIE

Sunday, March 10, 2013

EIGRP Practice Lab - For CCNP/CCIP/CCDP ROUTE Candidates (With Video Solutions)

PHYSICAL TOPOLOBY

LOGICAL TOPOLOBY 
Lab Task List


IOS Details

GNS Project File


Initial Configurations:
###################

R1
===

!
en
!
conf t
!
no cdp run
!
ho R1
!
no ip do lo
!
int lo0
 ip add 1.1.1.1 255.255.255.255
 exit
!
int s0/0
 encap frame
 ip add 123.0.0.1 255.255.255.0
 no frame inv
 frame map ip 123.0.0.2 102 b
 frame map ip 123.0.0.3 103 b
 frame map ip 123.0.0.1 102
 no sh
 exit
!
line con 0
 logging syn
 no exec-time
!
end
!

##########################################


R2
==

!
en
!
conf t
!
no cdp run
!
ho R2
!
no ip do lo
!
int lo0
 ip add 2.2.2.2 255.255.255.255
 exit
!
int s0/0
 encap frame
 ip add 123.0.0.2 255.255.255.0
 no frame inv
 frame map ip 123.0.0.1 201 b
 frame map ip 123.0.0.3 201
 frame map ip 123.0.0.2 201
 no sh
 exit
!
int s0/1
 encap frame
 ip add 205.0.0.2 255.255.255.0
 no frame inv
 frame map ip 205.0.0.5 205 b
 frame map ip 205.0.0.2 205
 no sh
 exit
!
int f0/0
 ip add 150.0.0.2 255.255.255.0
 no sh
 exit
!
int f0/1
 ip add 26.0.0.2 255.255.255.0
 no sh
 exit
!
int f1/0
 ip add 25.0.0.2 255.255.255.0
 no sh
 exit
!
line con 0
 logging syn
 no exec-time
!
end
!



##########################################


R3
===


!
en
!
conf t
!
no cdp run
!
ho R3
!
no ip do lo
!
int lo0
 ip add 3.3.3.3 255.255.255.255
 exit
!
int s0/0
 ip add 123.0.0.3 255.255.255.0
 encap frame
 no frame inv
 frame map ip 123.0.0.1 301 b
 frame map ip 123.0.0.2 301
 frame map ip 123.0.0.3 301
 no sh
 exit
!
line con 0
 logging syn
 no exec-time
!
end
!


##########################################

R4
===

!
en
!
conf t
!
no cdp run
!
ho R4
!
no ip do lo
!
int lo0
 ip add 4.4.4.4 255.255.255.255
 exit
!
int f0/0
 ip add 150.0.0.4 255.255.255.0
 no sh
 exit
!
int f0/1
 ip add 46.0.0.4 255.255.255.0
 no sh
 exit
!
int f1/0
 ip add 45.0.0.4 255.255.255.0
 no sh
 exit
!
line con 0
 logging syn
 no exec-time
!
end
!


##########################################


R5
===

!
en
!
conf t
!
no cdp run
!
ho R5
!
no ip do lo
!
int lo0
 ip add 5.5.5.5 255.255.255.255
 exit
!
int f0/0
 ip add 150.0.0.5 255.255.255.0
 no sh
 exit
!
int f0/1
 ip add 25.0.0.5 255.255.255.0
 no sh
 exit
!
int f1/0
 ip add 45.0.0.5 255.255.255.0
 no sh
 exit
!
line con 0
 logging syn
 no exec-time
!
end
!

##########################################


R6
===


!
en
!
conf t
!
no cdp run
!
ho R6
!
no ip do lo
!
int lo0
 ip add 6.6.6.6 255.255.255.255
 exit
!
int f0/0
 ip add 150.0.0.6 255.255.255.0
 no sh
 exit
!
int f0/1
 ip add 46.0.0.6 255.255.255.0
 no sh
 exit
!
int f1/0
 ip add 26.0.0.6 255.255.255.0
 no sh
 exit
!
line con 0
 logging syn
 no exec-time
!
end
!


Solution Videos

 TASK 1& 2 Solution




TASK 3 Solution




TASK 4 Solution



TASK 5 Solution



TASK 6 Solution



TASK 7 Solution


TASK 8 Solution


TASK 9 Solution


TASK 10 Solution



TASK 11 Solution



TASK 12 Solution


TASK 13 Solution


TASK 14 Solution


TASK 15 Solution



HTH...
Deepak Arora

Evil CCIE

Thursday, March 7, 2013

Cisco ME 3400 Metro Ethernet Switching Notes



> All ports are in shutdown mode by default

> No DTP Supported

> Trunks only support 802.1Q Encapsulation

> No VTP Supported

> Rapid PVST is default STP mode

> By default all Down stream ports are configured as port type UNI

> By default all Up stream ports are configured as port type NNI

> port-type [UNI|ENI|NNI]

> UNI can only send traffic to NNI

> UNI Don't support  - STP, CDP/LLDP, LACP/PAGP but ENI Does but must be manually enabled

> "sh port-type" to verify Port Type Status of any given interface

>"uni-vlan isolated|community" default is "isolated"..... the command doesn't apply to VLAN 1. Configuration goes under VLAN mode.

> Local UNI interface can't ping local SVI for same VLAN it is in without "IP Routing" turned ON but can ping  remote switch SVI for same VLAN.

> NNI Port in ME = Regular Port in Cat IOS



HTH...
Deeepak Arora
Evil CCIE